Back to overview
Downtime

Network Incident – FIN03 & FIN02 Datacenter Impact

Feb 20, 2026 at 6:00pm UTC
Affected services
Finland-02
Finland-03
Spot Instances
On-Demand Instances
Continuous Containers
Batch Job Containers

Resolved
Feb 20, 2026 at 7:40pm UTC

We would like to provide a final summary regarding the incident affecting FIN02 and FIN03.
The disruption was caused by an external network provider incident within Cloudflare's infrastructure, specifically impacting a subset of BYOIP prefix advertisements. During this time, customers may have experienced errors or timeouts reaching services routed through Cloudflare's network.
According to Cloudflare's public status updates, they identified and mitigated the underlying issue and subsequently worked to restore affected prefix advertisements. As Cloudflare restored network availability, our services in FIN03 and FIN02 progressively recovered.
All services are now fully operational, and traffic has returned to normal levels. The total duration of degraded performance and downtime was approximately 1 hour and 23 minutes.
While the root cause originated outside of our infrastructure, we take the impact to your workloads seriously. We are reviewing additional mitigation measures to reduce exposure to similar third-party network events in the future.
We sincerely apologize for the disruption and appreciate your continued trust and partnership.

Updated
Feb 20, 2026 at 7:35pm UTC

We are happy to report that the FIN02 datacenter services have been successfully restored.

All affected services are now fully operational and functioning as expected. The team will continue to closely monitor the systems to ensure ongoing stability.

Thank you for your patience and understanding during this incident.

Updated
Feb 20, 2026 at 6:59pm UTC

Services in the FIN03 datacenter have been successfully restored and are operating normally.

At this time, the incident remains ongoing in the FIN02 datacenter. Our team is actively applying patches and working to fully resolve the issue as soon as possible.

We will continue to share updates as progress is made.

Updated
Feb 20, 2026 at 6:39pm UTC

We would like to provide an update regarding the ongoing incident.

The issue in the FIN03 datacenter is most likely related to an impact on Cloudflare services. Our team is actively working to implement a patch and restore normal operations as quickly as possible.

Additionally, the FIN02 datacenter is now also experiencing related impact.

The team is fully engaged and continuing investigation and remediation efforts. We will share further updates as more information becomes available.

Created
Feb 20, 2026 at 6:00pm UTC

We are currently experiencing an ongoing incident in the FIN03 datacenter. As a result, related services are impacted.

Our team has been notified and is actively investigating the issue. We are working to identify the root cause and implement a fix as quickly as possible.

We will provide further updates as more information becomes available.

Thank you for your patience.