Back to overview
Degraded

An incident involving an SFS storage volume in FIN03.

Dec 30 at 01:00pm EET
Affected services
Finland-03
Shared Filesystem

Resolved
Dec 30 at 04:00pm EET

The incident related to the SFS volume transfer from ICE01 to FIN03 has been resolved.

The faulty transfer process has been stopped, safeguards have been put in place to prevent similar overwrite scenarios, and additional validation checks have been implemented for future migrations.

Unfortunately, due to the nature of the overwrite, some customer data could not be recovered. We sincerely apologize for the impact this incident has caused.

We are completing a full post-incident review and will be sharing follow-up communications with affected customers regarding remediation steps and preventive measures.

Thank you for your patience and understanding.

Updated
Dec 30 at 02:00pm EET

We have identified the root cause of the incident.

During the migration process, a configuration error resulted in partial overwriting of data on the FIN03 volume. This caused irreversible data loss for a subset of customer data stored on that volume.

We want to emphasize that this incident did not involve unauthorized access, data exposure, or data exfiltration.

We are currently:
Assessing the exact scope of impacted customers
Reviewing available recovery options
Conducting an internal incident review to prevent recurrence
Impacted customers will receive direct communication with next steps.

Created
Dec 30 at 01:00pm EET

We are currently investigating an incident involving an SFS storage volume transfer from ICE01 to FIN03.

At this time, there is no evidence of any data breach or data exfiltration. The issue is isolated to the transfer process itself.

Our engineering team is actively investigating the scope and impact of the incident. We will provide further updates as soon as more information becomes available.