Back to overview
Degraded

Storage volume reachability degraded in FIN-03

May 26, 2026 at 12:49pm UTC
Affected services
Finland-03
Spot Instances
On-Demand Instances
Block Volumes

Resolved
May 26, 2026 at 1:19pm UTC

Storage volume reachability in FIN-03 has recovered and the platform is operating normally again. We are continuing to monitor closely to ensure stability.

If your instance still appears unresponsive, restarting it from the console should resolve the issue. Please reach out to support if you continue to experience problems.

Thank you for your patience.

Created
May 26, 2026 at 12:49pm UTC

We are currently investigating reachability issues affecting some storage volumes in the FIN-03 region. Customers may experience degraded read/write performance when starting new instances that depend on the affected volumes.