Back to overview
Downtime

We have detected an issue impacting the FIN01 datacenter

Mar 15, 2026 at 11:49pm UTC
Affected services
Finland-01
Spot Instances
On-Demand Instances
Block Volumes
Shared Filesystem
Finland-01 Network

Resolved
Mar 16, 2026 at 3:18am UTC

The issue impacting the FIN01 datacenter has now been resolved. Traffic has been successfully rerouted and services have returned to normal operation. We will continue monitoring to ensure stability.

Updated
Mar 16, 2026 at 12:15am UTC

Our team has identified that a Key component in the FIN01 datacenter is currently down, which is causing the ongoing disruption. The network team is actively working on mitigation and is rerouting traffic to restore service availability.

Created
Mar 15, 2026 at 11:49pm UTC

We have detected an issue affecting the FIN01 datacenter, and some services may currently be unavailable. Our engineering team is actively investigating the problem and working to identify the root cause. We will share additional updates as soon as more information becomes available.